high8.8
CVE-2019-10437
Jenkins CRX Content Package Deployer Plugin subject to Cross-Site Request Forgery
Impact
A cross-site request forgery vulnerability in Jenkins CRX Content Package Deployer Plugin prior to 1.9 allowed attackers to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. This issue is patched in version 1.9
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.jenkins-ci.plugins:crx-content-package-deployer | < 1.9 | 1.9 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Jenkins | Crx Content Package Deployer | through 1.8.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://jenkins.io/security/advisory/2019-10-16/#SECURITY-1006%20%281%29
- https://github.com/advisories/GHSA-62fp-j75q-mqhc
- https://nvd.nist.gov/vuln/detail/CVE-2019-10437
- https://jenkins.io/security/advisory/2019-10-16/#SECURITY-1006%20(1)
- https://github.com/jenkinsci/crx-content-package-deployer-plugin/commit/1313c422170a064dab0f9359324ff27e30a9f4a5