high7.5
CVE-2019-10742
Denial of Service in axios
Impact
Versions of `axios` prior to 0.18.1 are vulnerable to Denial of Service. If a request exceeds the `maxContentLength` property, the package prints an error but does not stop the request. This may cause high CPU usage and lead to Denial of Service. ## Recommendation Upgrade to 0.18.1 or later.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | axios | <= 0.18.0 | 0.18.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Axios | Axios | through 0.18.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://app.snyk.io/vuln/SNYK-JS-AXIOS-174505
- https://github.com/axios/axios/issues/1098
- https://github.com/axios/axios/pull/1485
- https://github.com/advisories/GHSA-42xw-2xvc-qx8m
- https://nvd.nist.gov/vuln/detail/CVE-2019-10742
- https://snyk.io/vuln/SNYK-JS-AXIOS-174505
- https://www.npmjs.com/advisories/880
- https://github.com/axios/axios/commit/acabfbdf00a58bb866c9d070e8a10d1d0dbeb572