NetSight
high7.5

CVE-2019-10767

Arbitrary File Write in iobroker.js-controller

Impact

Versions of `iobroker.controller` prior to 2.0.25 are vulnerable to Path Traversal. The package fails to restrict access to folders outside of the intended `/adapter/<adapter-name>` folder, which may allow attackers to include arbitrary files in the system. An attacker would need to be authenticated to perform the attack but the package has authentication disabled by default. ## Recommendation Upgrade to version 2.0.25 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmiobroker.js-controller< 2.0.252.0.25

Affected products

VendorProductAffected versions
IobrokerIobroker.Js-Controller
before 2.0.25

Weakness classification

References