NetSight
medium6.1

CVE-2019-10785

XSS in dojox due to insufficient escape in dojox.xmpp.util.xmlEncode

Impact

### Impact _What kind of vulnerability is it? Who is impacted?_ Potential XSS vulnerability for users of `dojox/xmpp` and `dojox/dtl`. ### Patches _Has the problem been patched? What versions should users upgrade to?_ Yes, patches are available for the 1.11 through 1.16 versions. Users should upgrade to one of these versions of Dojo: * 1.16.1 * 1.15.2 * 1.14.5 * 1.13.6 * 1.12.7 * 1.11.9 Users of Dojo 1.10.x and earlier should review this change and determine if it impacts them, and backport the change as appropriate. ### Workarounds _Is there a way for users to fix or remediate the vulnerability without upgrading?_ The change applied in https://github.com/dojo/dojox/pull/315 could get added separately as a patch. ### For more information If you have any questions or comments about this advisory: * Open an issue in [dojo/dojox](https://github.com/dojo/dojox/)

Affected packages

EcosystemPackageAffectedFixed in
npmdojox< 1.11.91.11.9

Affected products

VendorProductAffected versions
LinuxfoundationDojox
from 1.11.0 before 1.11.9
from 1.12.0 before 1.12.7
from 1.13.0 before 1.13.6
from 1.14.0 before 1.14.5
from 1.15.0 before 1.15.2
from 1.16.0 before 1.16.1
DebianDebian Linux
Version 8.0

Weakness classification

References