high7.5
CVE-2019-12472
MediaWiki Incorrect Access Control vulnerability
Impact
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | mediawiki/core | >= 1.18.0, < 1.27.6 | 1.27.6 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Mediawiki | Mediawiki | from 1.18.0 before 1.27.6 from 1.30.0 before 1.30.2 from 1.31.0 before 1.31.2 from 1.32.0 before 1.32.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html
- https://phabricator.wikimedia.org/T199540
- https://github.com/advisories/GHSA-7mqg-5fgh-xh4r
- https://nvd.nist.gov/vuln/detail/CVE-2019-12472
- https://github.com/FriendsOfPHP/security-advisories/blob/master/mediawiki/core/CVE-2019-12472.yaml