NetSight
high7.5

CVE-2019-13118

libxslt Type Confusion vulnerability that affects Nokogiri

Impact

In `numbers.c` in libxslt 1.1.33, a type holding grouping characters of an `xsl:number` instruction was too narrow and an invalid character/length combination could be passed to `xsltNumberFormatDecimal`, leading to a read of uninitialized stack data. Nokogiri prior to version 1.10.5 used a vulnerable version of libxslt. Nokogiri 1.10.5 updated libxslt to version 1.1.34 to address this and other vulnerabilities in libxslt.

Affected packages

EcosystemPackageAffectedFixed in
rubygemsnokogiri< 1.10.51.10.5

Affected products

VendorProductAffected versions
XmlsoftLibxslt
Version 1.1.33
OpensuseLeap
Version 15.1
NetappActive Iq Unified Manager
All versions
NetappCloud Backup
All versions
NetappClustered Data Ontap
All versions
NetappE-Series Performance Analyzer
All versions
NetappE-Series Santricity Management Plug-Ins
All versions
NetappE-Series Santricity Os Controller
from 11.0 through 11.50.2
NetappE-Series Santricity Storage Manager
All versions
NetappE-Series Santricity Web Services
All versions
NetappOncommand Insight
All versions
NetappOncommand Workflow Automation
All versions

Weakness classification

References