NetSight
critical5.7

CVE-2019-16761

Validation Bypass in slp-validate

Impact

Versions of `slp-validate` prior to 1.0.1 are vulnerable to a validation bypass. Bitcoin scripts may cause the validation result from `slp-validate` to differ from the specified SLP consensus. This allows an attacker to create a Bitcoin script that causes a hard-fork from the SLP consensus. ## Recommendation Upgrade to version 1.0.1 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmslp-validate= 1.0.01.0.1

Affected products

VendorProductAffected versions
SimpleledgerSlp-Validate
Version 1.0.0

Weakness classification

References