NetSight
medium4.8

CVE-2019-16763

Pannellum Cross-Site Scripting due to data not being sanitized for URIs or vbscript

Impact

Versions of `pannellum` prior to 2.5.6 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize URLs for data URIs, which may allow attackers to execute arbitrary code in a victim's browser. ## Recommendation Upgrade to version 2.5.6 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmpannellum>= 2.5.0, < 2.5.52.5.5

Affected products

VendorProductAffected versions
PannellumPannellum
from 2.5.0 through 2.5.4

Weakness classification

References