NetSight
low3.1

CVE-2019-16772

Cross-Site Scripting in serialize-to-js

Impact

Versions of `serialize-to-js` prior to 3.0.1 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize serialized regular expressions. This vulnerability does not affect Node.js applications. ## Recommendation Upgrade to version 3.0.1 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmserialize-to-js< 3.0.13.0.1

Affected products

VendorProductAffected versions
Serialize-To-Js ProjectSerialize-To-Js
before 3.0.1

Weakness classification

References