NetSight
high6.9

CVE-2019-16791

postfix-mta-sts-resolver Algorithm Downgrade vulnerability

Impact

## Incorrect query parsing ### Impact All users of versions prior to 0.5.1 can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy. ### Patches Problem has been patched in version 0.5.1 ### Workarounds Users may remediate this vulnerability without upgrading by applying [these patches](https://gist.github.com/Snawoot/b9da85d6b26dea5460673b29df1adc6b) to older suppoorted versions. ### For more information If you have any questions or comments about this advisory: * Open an issue in [postfix-mta-sts-resolver repo](https://github.com/Snawoot/postfix-mta-sts-resolver) * Email me at [vladislav at vm-0 dot com](mailto:vladislav-ex-gh-advisory@vm-0.com)

Affected packages

EcosystemPackageAffectedFixed in
pippostfix-mta-sts-resolver< 0.5.10.5.1

Affected products

VendorProductAffected versions
Postfix-Mta-Sts-Resolver ProjectPostfix-Mta-Sts-Resolver
before 0.5.1

Weakness classification

References