NetSight
high7.5

CVE-2019-17592

Regular Expression Denial of Service in csv-parse

Impact

Versions of `csv-parse` prior to 4.4.6 are vulnerable to Regular Expression Denial of Service. The `__isInt()` function contains a malformed regular expression that processes large specially-crafted input very slowly, leading to a Denial of Service. This is triggered when using the `cast` option. ## Recommendation Upgrade to version 4.4.6 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmcsv-parse< 4.4.64.4.6

Affected products

VendorProductAffected versions
Csv-Parse ProjectCsv-Parse
before 4.4.6
FedoraprojectFedora
Version 31

Weakness classification

References