NetSight
critical9.8

CVE-2019-25158

Pedroetb TTS-API OS Command Injection

Impact

A vulnerability has been found in pedroetb tts-api up to 2.1.4 and classified as critical. This vulnerability affects the function onSpeechDone of the file app.js. The manipulation leads to os command injection. Upgrading to version 2.2.0 is able to address this issue. The patch is identified as 29d9c25415911ea2f8b6de247cb5c4607d13d434. It is recommended to upgrade the affected component. VDB-248278 is the identifier assigned to this vulnerability.

Affected packages

EcosystemPackageAffectedFixed in
npmtts-api< 2.2.02.2.0

Affected products

VendorProductAffected versions
PedroetbTts-Api
before 2.2.0

Weakness classification

References