critical9.8
CVE-2019-7139
Magento 2 Community Edition SQLi Vulnerability
Impact
An unauthenticated user can execute SQL statements that allow arbitrary read access to the underlying database, which causes sensitive data leakage. This issue is fixed in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | magento/community-edition | >= 2.1.0, < 2.1.18 | 2.1.18 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Magento | Magento | before 1.9.4.1 from 1.14.0.0 before 1.14.4.1 from 2.1.0 before 2.1.17 from 2.2.0 before 2.2.8 from 2.3.0 before 2.3.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13
- https://www.ambionics.io/blog/magento-sqli
- https://github.com/advisories/GHSA-4j6w-9rf8-hg7r
- https://nvd.nist.gov/vuln/detail/CVE-2019-7139
- https://web.archive.org/web/20211206084839/https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/magento1ce/CVE-2019-7139.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/magento1ee/CVE-2019-7139.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-7139.yaml
- https://magento.com/security/patches/supee-11086