medium5.3
CVE-2019-8123
Magento 2 Community Edition Insufficient Logging
Impact
An insufficient logging and monitoring vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. The logging feature required for effective monitoring did not contain sufficent data to effectively track configuration changes. As per [the Magento Release 2.3.3](https://web.archive.org/web/20201126132230/https://devdocs.magento.com/guides/v2.3/release-notes/release-notes-2-3-3-commerce.html#new-security-only-patch-available), if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | magento/community-edition | >= 2.1.0, < 2.1.19 | 2.1.19 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Magento | Magento | before 1.9.3.4 before 1.14.4.3 from 2.2.0 before 2.2.10 from 2.3.0 through 2.3.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://magento.com/security/patches/supee-11219
- https://github.com/advisories/GHSA-fp5m-4mqh-849p
- https://nvd.nist.gov/vuln/detail/CVE-2019-8123
- https://web.archive.org/web/20211209030216/https://magento.com/security/patches/supee-11219
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/magento1ce/CVE-2019-8123.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/magento1ee/CVE-2019-8123.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8123.yaml
- https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update