NetSight
high8.8

CVE-2019-8154

Magento remote code execution vulnerability

Impact

A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with privileges to modify product catalogs can trigger PHP file inclusion through a crafted XML file that specifies product design update. As per [the Magento Release 2.3.3](https://web.archive.org/web/20201126132230/https://devdocs.magento.com/guides/v2.3/release-notes/release-notes-2-3-3-commerce.html#new-security-only-patch-available), if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.

Affected packages

EcosystemPackageAffectedFixed in
composermagento/community-edition>= 2.2.0, < 2.2.102.2.10

Affected products

VendorProductAffected versions
MagentoMagento
from 2.2.0 before 2.2.10
from 2.3.0 before 2.3.2
Version 2.3.2

Weakness classification

References