critical9.8
CVE-2019-8158
Magento 2 Community Edition XML Injection
Impact
An XPath entity injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An attacker can craft a GET request to page cache block rendering module that gets passed to XML data processing engine without validation. The crafted key/value GET request data allows an attacker to limited access to underlying XML data. As per [the Magento Release 2.3.3](https://web.archive.org/web/20201126132230/https://devdocs.magento.com/guides/v2.3/release-notes/release-notes-2-3-3-commerce.html#new-security-only-patch-available), if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | magento/community-edition | >= 2.2.0, < 2.2.10 | 2.2.10 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Magento | Magento | from 2.2.0 before 2.2.10 from 2.3.0 before 2.3.2 Version 2.3.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
- https://github.com/advisories/GHSA-8p5c-f836-m4h7
- https://nvd.nist.gov/vuln/detail/CVE-2019-8158
- https://web.archive.org/web/20220121051105/https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8158.yaml