high7.5
CVE-2019-8322
RubyGems Escape sequence injection vulnerability in gem owner
Impact
An issue was discovered in RubyGems 2.6 and later through 3.0.2. The gem owner command outputs the contents of the API response directly to stdout. Therefore, if the response is crafted, escape sequence injection may occur.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rubygems | rubygems-update | >= 2.6.0, < 2.7.9 | 2.7.9 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Rubygems | Rubygems | from 2.6.0 through 3.0.2 |
| Debian | Debian Linux | Version 9.0 |
| Opensuse | Leap | Versions 15.0, 15.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
- https://hackerone.com/reports/315087
- https://lists.debian.org/debian-lts-announce/2020/08/msg00027.html
- https://github.com/advisories/GHSA-mh37-8c3g-3fgc
- https://nvd.nist.gov/vuln/detail/CVE-2019-8322
- https://blog.rubygems.org/2019/03/05/security-advisories-2019-03.html
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rubygems-update/CVE-2019-8322.yml