NetSight
critical9.8

CVE-2020-10018

WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that ma…

Impact

WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that may lead to arbitrary code execution. This issue has been fixed in 2.28.0 with improved memory handling.

Affected products

VendorProductAffected versions
WebkitgtkWebkitgtk
before 2.28.0
WpewebkitWpe Webkit
before 2.28.0
FedoraprojectFedora
Versions 30, 31
DebianDebian Linux
Version 10.0
CanonicalUbuntu Linux
Versions 18.04, 19.10
OpensuseLeap
Version 15.1

Weakness classification

References