medium6.5
CVE-2020-11017
In FreeRDP less than or equal to 2.0.0, by providing manipulated input a malicious client can create a double free condition and crash the server.
Impact
In FreeRDP less than or equal to 2.0.0, by providing manipulated input a malicious client can create a double free condition and crash the server. This is fixed in version 2.1.0.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Freerdp | Freerdp | before 2.1.0 |
| Opensuse | Leap | Version 15.1 |
| Debian | Debian Linux | Version 10.0 |
Weakness classification
References
- NVD record
- CVE.org record
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00080.html
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-q5c8-fm29-q57c
- https://lists.debian.org/debian-lts-announce/2023/10/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00080.html
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-q5c8-fm29-q57c
- https://lists.debian.org/debian-lts-announce/2023/10/msg00008.html