high8.5
CVE-2020-11020
Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system.
Impact
Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Faye Project | Faye | after 0.5.0 before 1.0.4 from 1.1.0 before 1.1.3 from 1.2.0 before 1.2.5 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/faye/faye/commit/65d297d341b607f3cb0b5fa6021a625a991cc30e
- https://github.com/faye/faye/security/advisories/GHSA-qpg4-4w7w-2mq5
- https://github.com/faye/faye/commit/65d297d341b607f3cb0b5fa6021a625a991cc30e
- https://github.com/faye/faye/security/advisories/GHSA-qpg4-4w7w-2mq5