high7.4Public exploit code
CVE-2020-11060
In GLPI before 9.4.6, an attacker can execute system commands by abusing the backup functionality.
Public exploit code
Working exploit or proof of concept code has been published for this vulnerability. Treat unpatched systems as at risk.
- GLPI GZIP(Py3) 9.4.5 - RCE2023-10-09 · webapps · php
- GLPI 9.4.5 - Remote Code Execution (RCE)2021-06-14 · webapps · php
Impact
In GLPI before 9.4.6, an attacker can execute system commands by abusing the backup functionality. Theoretically, this vulnerability can be exploited by an attacker without a valid account by using a CSRF. Due to the difficulty of the exploitation, the attack is only conceivable by an account having Maintenance privileges and the right to add WIFI networks. This is fixed in version 9.4.6.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Glpi-Project | Glpi | before 9.4.6 |
Weakness classification
References
- NVD record
- CVE.org record
- http://packetstormsecurity.com/files/163119/GLPI-9.4.5-Remote-Code-Execution.html
- https://github.com/glpi-project/glpi/commit/ad748d59c94da177a3ed25111c453902396f320c
- https://github.com/glpi-project/glpi/security/advisories/GHSA-cvvq-3fww-5v6f
- http://packetstormsecurity.com/files/163119/GLPI-9.4.5-Remote-Code-Execution.html
- https://github.com/glpi-project/glpi/commit/ad748d59c94da177a3ed25111c453902396f320c
- https://github.com/glpi-project/glpi/security/advisories/GHSA-cvvq-3fww-5v6f