medium6.4
CVE-2020-11082
In Kaminari before 1.2.1, there is a vulnerability that would allow an attacker to inject arbitrary code into pages with pagination links.
Impact
In Kaminari before 1.2.1, there is a vulnerability that would allow an attacker to inject arbitrary code into pages with pagination links. This has been fixed in 1.2.1.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Kaminari Project | Kaminari | before 1.2.1 |
| Debian | Debian Linux | Versions 9.0, 10.0 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/github/advisory-review/pull/1020
- https://github.com/kaminari/kaminari/commit/8dd52a1aed3d2fa2835d836de23fc0d8c4ff5db8
- https://github.com/kaminari/kaminari/security/advisories/GHSA-r5jw-62xg-j433
- https://lists.debian.org/debian-lts-announce/2021/09/msg00011.html
- https://www.debian.org/security/2021/dsa-5005
- https://github.com/github/advisory-review/pull/1020
- https://github.com/kaminari/kaminari/commit/8dd52a1aed3d2fa2835d836de23fc0d8c4ff5db8
- https://github.com/kaminari/kaminari/security/advisories/GHSA-r5jw-62xg-j433
- https://lists.debian.org/debian-lts-announce/2021/09/msg00011.html
- https://www.debian.org/security/2021/dsa-5005