medium6.1
CVE-2020-13627
Cross-site scripting (XSS) vulnerability allows remote attackers to inject arbitrary web script or HTML via the widgetId parameter to service-monitoring/src/in…
Impact
Cross-site scripting (XSS) vulnerability allows remote attackers to inject arbitrary web script or HTML via the widgetId parameter to service-monitoring/src/index.php. This vulnerability is fixed in versions 1.6.4, 18.10.3, 19.04.3, and 19.0.1 of the Centreon host-monitoring widget; 1.6.4, 18.10.5, 19.04.3, 19.10.2 of the Centreon service-monitoring widget; and 1.0.3, 18.10.1, 19.04.1, 19.10.1 of the Centreon tactical-overview widget.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Centreon | Centreon Host-Monitoring Widget | before 1.6.4 from 18.10.0 before 18.10.3 from 19.0.0 before 19.0.1 from 19.04.0 before 19.04.3 |
| Centreon | Centreon Tactical-Overview Widget | before 1.0.3 from 18.10.0 before 18.10.1 from 19.04.0 before 19.04.1 from 19.10.0 before 19.10.1 |
| Centreon | Centreon Service-Monitoring Widget | before 1.6.4 from 18.10.0 before 18.10.5 from 19.04.0 before 19.04.3 from 19.10.0 before 19.10.2 |