NetSight
critical9.8

CVE-2020-13925

Command Injection in Kylin

Impact

Similar to CVE-2020-1956, Kylin has one more restful API which concatenates the API inputs into OS commands and then executes them on the server; while the reported API misses necessary input validation, which causes the hackers to have the possibility to execute OS command remotely. Users of all previous versions after 2.3 should upgrade to 3.1.0.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.kylin:kylin-server-base< 3.1.03.1.0

Affected products

VendorProductAffected versions
ApacheKylin
from 2.3.0 before 3.1.0

Weakness classification

References