NetSight
critical9.8

CVE-2020-13942

Injection and Improper Input Validation in Apache Unomi

Impact

It is possible to inject malicious OGNL or MVEL scripts into the /context.json public endpoint. This was partially fixed in 1.5.1 but a new attack vector was found. In Apache Unomi version 1.5.2 scripts are now completely filtered from the input. It is highly recommended to upgrade to the latest available version of the 1.5.x release to fix this problem.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.unomi:unomi< 1.5.21.5.2

Affected products

VendorProductAffected versions
ApacheUnomi
from 1.5.0 before 1.5.2

Weakness classification

References