NetSight
critical9.0

CVE-2020-15150

Remote Code Execution in paginator

Impact

There is a vulnerability in Paginator which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the `paginate()` function. ### Impact There is a vulnerability in Paginator which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the `paginate()` function. This will potentially affect all current users of `Paginator` prior to version >= 1.0.0. ### Patches The vulnerability has been patched in version 1.0.0 and all users should upgrade to this version immediately. Note that this patched version uses a dependency that requires an Elixir version >=1.5. ### Credits Thank you to Peter Stöckli.

Affected packages

EcosystemPackageAffectedFixed in
erlangpaginator< 1.0.01.0.0

Affected products

VendorProductAffected versions
DuffelPaginator
before 1.0.0

Weakness classification

References