medium5.4
CVE-2020-15162
In PrestaShop from version 1.5.0.0 and before version 1.7.6.8, users are allowed to send compromised files.
Impact
In PrestaShop from version 1.5.0.0 and before version 1.7.6.8, users are allowed to send compromised files. These attachments allowed people to input malicious JavaScript which triggered an XSS payload. The problem is fixed in version 1.7.6.8.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Prestashop | Prestashop | from 1.5.0.0 before 1.7.6.8 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/PrestaShop/PrestaShop/commit/2cfcd33c75974a49f17665f294f228454e14d9cf
- https://github.com/PrestaShop/PrestaShop/releases/tag/1.7.6.8
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-rc8c-v7rq-q392
- https://github.com/PrestaShop/PrestaShop/commit/2cfcd33c75974a49f17665f294f228454e14d9cf
- https://github.com/PrestaShop/PrestaShop/releases/tag/1.7.6.8
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-rc8c-v7rq-q392