NetSight
high7.5

CVE-2020-15166

In ZeroMQ before version 4.3.3, there is a denial-of-service vulnerability.

Impact

In ZeroMQ before version 4.3.3, there is a denial-of-service vulnerability. Users with TCP transport public endpoints, even with CURVE/ZAP enabled, are impacted. If a raw TCP socket is opened and connected to an endpoint that is fully configured with CURVE/ZAP, legitimate clients will not be able to exchange any message. Handshakes complete successfully, and messages are delivered to the library, but the server application never receives them. This is patched in version 4.3.3.

Affected products

VendorProductAffected versions
ZeromqLibzmq
before 4.3.3
FedoraprojectFedora
Versions 32, 33
DebianDebian Linux
Version 9.0

Weakness classification

References