NetSight
medium5.3

CVE-2020-15194

Denial of Service in Tensorflow

Impact

### Impact The `SparseFillEmptyRowsGrad` implementation has incomplete validation of the shapes of its arguments: https://github.com/tensorflow/tensorflow/blob/0e68f4d3295eb0281a517c3662f6698992b7b2cf/tensorflow/core/kernels/sparse_fill_empty_rows_op.cc#L235-L241 Although `reverse_index_map_t` and `grad_values_t` are accessed in a similar pattern, only `reverse_index_map_t` is validated to be of proper shape. Hence, malicious users can pass a bad `grad_values_t` to trigger an assertion failure in `vec`, causing denial of service in serving installations. ### Patches We have patched the issue in 390611e0d45c5793c7066110af37c8514e6a6c54 and will release a patch release for all affected versions. We recommend users to upgrade to TensorFlow 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1. ### For more information Please consult [our security guide](https://github.com/tensorflow/tensorflow/blob/master/SECURITY.md) for more information regarding the security model and how to contact us with issues and questions. ### Attribution This vulnerability is a variant of [GHSA-63xm-rx5p-xvqr](https://github.com/tensorflow/tensorflow/security/advisories/GHSA-63xm-rx5p-xvqr)

Affected packages

EcosystemPackageAffectedFixed in
piptensorflow< 1.15.41.15.4
piptensorflow-cpu< 1.15.41.15.4
piptensorflow-gpu< 1.15.41.15.4

Affected products

VendorProductAffected versions
GoogleTensorflow
before 1.15.4
from 2.0.0 before 2.0.3
from 2.1.0 before 2.1.2
from 2.2.0 before 2.2.1
from 2.3.0 before 2.3.1
OpensuseLeap
Version 15.2

Weakness classification

References