NetSight
critical9.3

CVE-2020-15271

Markdown-supplied Shell Command Execution

Impact

### Impact lookatme versions prior to 2.3.0 automatically loaded the built-in "terminal" and "file_loader" extensions. Users that use lookatme to render untrusted markdown may have malicious shell commands automatically run on their system. ### Patches Users should upgrade to lookatme versions 2.3.0 or above. ### Workarounds The `lookatme/contrib/terminal.py` and `lookatme/contrib/file_loader.py` files may be manually deleted. Additionally, it is always recommended to be aware of what is being rendered with lookatme. ### References * https://github.com/d0c-s4vage/lookatme/pull/110 * https://github.com/d0c-s4vage/lookatme/releases/tag/v2.3.0 ### For more information If you have any questions or comments about this advisory: * Open an issue in [d0c-s4vage/lookatme](https://github.com/d0c-s4vage/lookatme)

Affected packages

EcosystemPackageAffectedFixed in
piplookatme< 2.3.02.3.0

Affected products

VendorProductAffected versions
Lookatme ProjectLookatme
before 2.3.0

Weakness classification

References