NetSight
high8.2

CVE-2020-16250

Authentication Bypass by Spoofing and Insufficient Verification of Data Authenticity in Hashicorp Vault

Impact

HashiCorp Vault and Vault Enterprise versions 0.7.1 and newer, when configured with the AWS IAM auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1..

Affected packages

EcosystemPackageAffectedFixed in
gogithub.com/hashicorp/vault>= 1.5.0, < 1.5.11.5.1

Affected products

VendorProductAffected versions
HashicorpVault
from 0.7.1 before 1.2.5
from 1.3.0 before 1.3.8
from 1.4.0 before 1.4.4
from 1.5.0 before 1.5.1

Weakness classification

References