high8.2
CVE-2020-16251
HashiCorp Vault Authentication bypass
Impact
HashiCorp Vault and Vault Enterprise versions 0.8.3 and newer, when configured with the GCP GCE auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/hashicorp/vault | >= 0.8.3, < 1.2.5 | 1.2.5 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Hashicorp | Vault | from 0.8.3 before 1.2.5 from 1.3.0 before 1.3.8 from 1.4.0 before 1.4.4 from 1.5.0 before 1.5.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://packetstormsecurity.com/files/159479/Hashicorp-Vault-GCP-IAM-Integration-Authentication-Bypass.html
- https://github.com/hashicorp/vault/blob/master/CHANGELOG.md#151
- https://www.hashicorp.com/blog/category/vault/
- https://github.com/advisories/GHSA-4mp7-2m29-gqxf
- https://nvd.nist.gov/vuln/detail/CVE-2020-16251
- https://www.hashicorp.com/blog/category/vault