medium6.1
CVE-2020-25628
Cross site-scripting (XSS) moodle
Impact
The filter in the tag manager required extra sanitizing to prevent a reflected XSS risk. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | moodle/moodle | >= 3.9.0, < 3.9.2 | 3.9.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Moodle | Moodle | from 3.5.0 before 3.5.14 from 3.7.0 before 3.7.8 from 3.8.0 before 3.8.5 from 3.9.0 before 3.9.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-69340
- https://moodle.org/mod/forum/discuss.php?d=410840
- https://github.com/advisories/GHSA-5x33-h32w-6vr2
- https://nvd.nist.gov/vuln/detail/CVE-2020-25628
- https://github.com/moodle/moodle/commit/e8632a4ad0b4da3763cbbe5949594aa449b483bb