NetSight
high8.8

CVE-2020-25629

A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access to some site admin…

Impact

A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access to some site administration capabilities by "logging in as" a System manager. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. This is fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

Affected products

VendorProductAffected versions
MoodleMoodle
from 3.5.0 before 3.5.14
from 3.7.0 before 3.7.8
from 3.8.0 before 3.8.5
from 3.9.0 before 3.9.2

Weakness classification

References