high7.5
CVE-2020-25630
A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user quota before unzipping them, which could le…
Impact
A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user quota before unzipping them, which could lead to a denial of service risk. This affects versions 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Moodle | Moodle | from 3.5.0 before 3.5.14 from 3.7.0 before 3.7.8 from 3.8.0 before 3.8.5 from 3.9.0 before 3.9.2 |