NetSight
medium5.3

CVE-2020-25701

Privilage Escalation in moodle

Impact

If the upload course tool in Moodle was used to delete an enrollment method which did not exist or was not already enabled, the tool would erroneously enable that enrollment method. This could lead to unintended users gaining access to the course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

Affected packages

EcosystemPackageAffectedFixed in
composermoodle/moodle>= 3.9.0, < 3.9.33.9.3

Affected products

VendorProductAffected versions
MoodleMoodle
from 3.5.0 through 3.5.14
from 3.7.0 through 3.7.8
from 3.8.0 through 3.8.5
from 3.9.0 through 3.9.2
FedoraprojectFedora
Versions 32, 33

Weakness classification

References