medium6.1
CVE-2020-25864
HashiCorp Consul Cross-site Scripting vulnerability
Impact
HashiCorp Consul and Consul Enterprise up to version 1.9.4 key-value (KV) raw mode was vulnerable to cross-site scripting. Fixed in 1.9.5, 1.8.10 and 1.7.14.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/hashicorp/consul | >= 1.9.0, < 1.9.5 | 1.9.5 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Hashicorp | Consul | before 1.7.14 from 1.8.0 before 1.8.10 from 1.9.0 before 1.9.5 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://discuss.hashicorp.com/t/hcsec-2021-07-consul-api-kv-endpoint-vulnerable-to-cross-site-scripting/23368
- https://security.gentoo.org/glsa/202208-09
- https://www.hashicorp.com/blog/category/consul
- https://github.com/advisories/GHSA-8xmx-h8rq-h94j
- https://nvd.nist.gov/vuln/detail/CVE-2020-25864