high7.7
CVE-2020-26223
Authorization bypass in Spree
Impact
### Impact The perpetrator could query the [API v2 Order Status](https://guides.spreecommerce.org/api/v2/storefront#tag/Order-Status) endpoint with an empty string passed as an Order token ### Patches Please upgrade to 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected. ### References Pull request with a fix and in-depth explanation - https://github.com/spree/spree/pull/10573 ### For more information If you have any questions or comments about this advisory: * Email us at [security@spreecommerce.org](mailto:security@spreecommerce.org)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rubygems | spree_api | >= 3.7.0, < 3.7.13 | 3.7.13 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Spreecommerce | Spree | from 3.7.0 before 3.7.13 from 4.0.0 before 4.0.5 from 4.1.0 before 4.1.12 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/spree/spree/pull/10573
- https://github.com/spree/spree/security/advisories/GHSA-m2jr-hmc3-qmpr
- https://guides.spreecommerce.org/api/v2/storefront#tag/Order-Status
- https://github.com/advisories/GHSA-m2jr-hmc3-qmpr
- https://rubygems.org/gems/spree_api/versions
- https://nvd.nist.gov/vuln/detail/CVE-2020-26223
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/spree_api/CVE-2020-26223.yml