NetSight
high8.7

CVE-2020-26309

nope-validator Regular Expression Denial of Service vulnerability

Impact

Nope is a JavaScript validator. Versions 0.11.3 and prior contain one or more regular expressions that are vulnerable to Regular Expression Denial of Service (ReDoS). This vulnerability is fixed in 0.12.1.

Affected packages

EcosystemPackageAffectedFixed in
npmnope-validator< 0.12.10.12.1

Weakness classification

References