medium6.1
CVE-2020-36644
Inline SVG vulnerable to Cross-site Scripting
Impact
A vulnerability has been found in jamesmartin Inline SVG up to 1.7.1 and classified as problematic. Affected by this vulnerability is an unknown functionality of the file `lib/inline_svg/action_view/helpers.rb` of the component `URL Parameter Handler`. The manipulation of the argument filename leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.7.2 is able to address this issue. The name of the patch is f5363b351508486021f99e083c92068cf2943621. It is recommended to upgrade the affected component. The identifier VDB-217597 was assigned to this vulnerability.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rubygems | inline_svg | < 1.7.2 | 1.7.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Inline Svg Project | Inline Svg | before 1.7.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/jamesmartin/inline_svg/commit/f5363b351508486021f99e083c92068cf2943621
- https://github.com/jamesmartin/inline_svg/pull/117
- https://github.com/jamesmartin/inline_svg/releases/tag/v1.7.2
- https://vuldb.com/?ctiid.217597
- https://vuldb.com/?id.217597
- https://github.com/advisories/GHSA-p33q-4h4m-j994
- https://nvd.nist.gov/vuln/detail/CVE-2020-36644
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/inline_svg/CVE-2020-36644.yml