NetSight
high7.4

CVE-2020-4038

GraphQL Playground (graphql-playground-html NPM package) before version 1.6.22 have a severe XSS Reflection attack vulnerability.

Impact

GraphQL Playground (graphql-playground-html NPM package) before version 1.6.22 have a severe XSS Reflection attack vulnerability. All unsanitized user input passed into renderPlaygroundPage() method could trigger this vulnerability. This has been patched in graphql-playground-html version 1.6.22. Note that some of the associated dependent middleware packages are also affected including but not limited to graphql-playground-middleware-express before version 1.7.16, graphql-playground-middleware-koa before version 1.6.15, graphql-playground-middleware-lambda before version 1.7.17, and graphql-playground-middleware-hapi before 1.6.13.

Affected products

VendorProductAffected versions
PrismaGraphql-Playground-Html
before 1.6.22
PrismaGraphql-Playground-Middleware-Express
before 1.7.16
PrismaGraphql-Playground-Middleware-Hapi
before 1.6.13
PrismaGraphql-Playground-Middleware-Koa
before 1.6.15
PrismaGraphql-Playground-Middleware-Lambda
before 1.7.17

Weakness classification

References