NetSight
medium5.7

CVE-2020-4048

In affected versions of WordPress, due to an issue in wp_validate_redirect() and URL sanitization, an arbitrary external link can be crafted leading to uninten…

Impact

In affected versions of WordPress, due to an issue in wp_validate_redirect() and URL sanitization, an arbitrary external link can be crafted leading to unintended/open redirect when clicked. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).

Affected products

VendorProductAffected versions
WordpressWordpress
from 3.7 before 3.7.34
from 3.8 before 3.8.34
from 3.9 before 3.9.32
from 4.0 before 4.0.31
from 4.1 before 4.1.31
from 4.2 before 4.2.28
FedoraprojectFedora
Versions 32, 33
DebianDebian Linux
Versions 8.0, 9.0, 10.0

Weakness classification

References