medium6.1
CVE-2020-5223
In PrivateBin versions 1.2.0 before 1.2.2, and 1.3.0 before 1.3.2, a persistent XSS attack is possible.
Impact
In PrivateBin versions 1.2.0 before 1.2.2, and 1.3.0 before 1.3.2, a persistent XSS attack is possible. Under certain conditions, a user provided attachment file name can inject HTML leading to a persistent Cross-site scripting (XSS) vulnerability. The vulnerability has been fixed in PrivateBin v1.3.2 & v1.2.2. Admins are urged to upgrade to these versions to protect the affected users.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Privatebin | Privatebin | from 1.2 before 1.2.2 from 1.3 before 1.3.2 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/PrivateBin/PrivateBin/commit/8d0ac336d23cd8c98e71d5f21cdadcae9c8a26e6
- https://github.com/PrivateBin/PrivateBin/issues/554
- https://github.com/PrivateBin/PrivateBin/security/advisories/GHSA-8j72-p2wm-6738
- https://privatebin.info/news/v1.3.2-v1.2.2-release.html
- https://github.com/PrivateBin/PrivateBin/commit/8d0ac336d23cd8c98e71d5f21cdadcae9c8a26e6
- https://github.com/PrivateBin/PrivateBin/issues/554
- https://github.com/PrivateBin/PrivateBin/security/advisories/GHSA-8j72-p2wm-6738
- https://privatebin.info/news/v1.3.2-v1.2.2-release.html