medium4.1
CVE-2020-5279
In PrestaShop between versions 1.5.0.0 and 1.7.6.5, there are improper access control since the the version 1.5.0.0 for legacy controllers.
Impact
In PrestaShop between versions 1.5.0.0 and 1.7.6.5, there are improper access control since the the version 1.5.0.0 for legacy controllers. - admin-dev/index.php/configure/shop/customer-preferences/ - admin-dev/index.php/improve/international/translations/ - admin-dev/index.php/improve/international/geolocation/ - admin-dev/index.php/improve/international/localization - admin-dev/index.php/configure/advanced/performance - admin-dev/index.php/sell/orders/delivery-slips/ - admin-dev/index.php?controller=AdminStatuses The problem is fixed in 1.7.6.5
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Prestashop | Prestashop | after 1.5.0.0 before 1.7.6.5 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/PrestaShop/PrestaShop/commit/4444fb85761667a2206874a3112ccc77f657d76a
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-74vp-ww64-w2gm
- https://github.com/PrestaShop/PrestaShop/commit/4444fb85761667a2206874a3112ccc77f657d76a
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-74vp-ww64-w2gm