NetSight
high7.5

CVE-2021-21317

Denial of Service in uap-core

Impact

## Impact Some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings. ## Patches Please update uap-core to >= v0.11.0 Downstream packages such as uap-python, uap-ruby etc which depend upon uap-core follow different version schemes.

Affected packages

EcosystemPackageAffectedFixed in
npmuap-core< 0.11.00.11.0

Affected products

VendorProductAffected versions
Uap-Core ProjectUap-Core
before 0.11.0

Weakness classification

References