NetSight
high7.4

CVE-2021-21361

Sensitive information disclosure via log in com.bmuschko:gradle-vagrant-plugin

Impact

### Impact The `com.bmuschko:gradle-vagrant-plugin` Gradle plugin contains an information disclosure vulnerability due to the logging of the system environment variables. When this Gradle plugin is executed in public CI/CD, this can lead to sensitive credentials being exposed to malicious actors. ### Patches Fixed in version 3.0.0 ### References - https://github.com/bmuschko/gradle-vagrant-plugin/blob/292129f9343d00d391543fae06239e9b0f33db73/src/main/groovy/com/bmuschko/gradle/vagrant/process/GDKExternalProcessExecutor.groovy#L42-L44 - https://github.com/bmuschko/gradle-vagrant-plugin/issues/19 - https://github.com/bmuschko/gradle-vagrant-plugin/pull/20 ### For more information If you have any questions or comments about this advisory: * Open an issue in [bmuschko/gradle-vagrant-plugin](https://github.com/bmuschko/gradle-vagrant-plugin)

Affected packages

EcosystemPackageAffectedFixed in
mavencom.bmuschko:gradle-vagrant-plugin>= 0.6, < 3.0.03.0.0

Affected products

VendorProductAffected versions
Vagrant ProjectVagrant
before 0.6
from 2.0 before 3.0.0

Weakness classification

References