medium5.4
CVE-2021-21370
Cross-Site Scripting in Content Preview (CType menu)
Impact
### Problem It has been discovered that content elements of type _menu_ are vulnerable to cross-site scripting when their referenced items get previewed in the page module. A valid backend user account is needed to exploit this vulnerability. ### Solution Update to TYPO3 versions 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1 that fix the problem described. ### Credits Thanks to TYPO3 contributor Oliver Bartsch who reported and fixed the issue. ### References * [TYPO3-CORE-SA-2021-008](https://typo3.org/security/advisory/typo3-core-sa-2021-008)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | typo3/cms-backend | >= 7.0.0, <= 7.6.50 | 7.6.51 |
| composer | typo3/cms-core | >= 10.0.0, < 10.4.14 | 10.4.14 |
| composer | typo3/cms | >= 10.0.0, < 10.4.14 | 10.4.14 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Typo3 | Typo3 | from 7.0.0 before 7.6.51 from 8.0.0 before 8.7.40 from 9.0.0 before 9.5.25 from 10.0.0 before 10.4.14 from 11.0.0 before 11.1.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/TYPO3/TYPO3.CMS/security/advisories/GHSA-x7hc-x7fm-f7qh
- https://packagist.org/packages/typo3/cms-backend
- https://typo3.org/security/advisory/typo3-core-sa-2021-008
- https://github.com/advisories/GHSA-x7hc-x7fm-f7qh
- https://nvd.nist.gov/vuln/detail/CVE-2021-21370
- https://github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms-core/CVE-2021-21370.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms/CVE-2021-21370.yaml