NetSight
high8.9

CVE-2021-21388

Command Injection Vulnerability in systeminformation

Impact

### Impact command injection vulnerability ### Patches Problem was fixed with a parameter check. Please upgrade to version >= 5.6.4 ### Workarounds If you cannot upgrade, be sure to check or sanitize service parameters that are passed to si.inetLatency(), si.inetChecksite(), si.services(), si.processLoad() ... do only allow strings, reject any arrays. String sanitation works as expected.

Affected packages

EcosystemPackageAffectedFixed in
npmsysteminformation< 5.6.45.6.4

Affected products

VendorProductAffected versions
SysteminformationSysteminformation
before 5.6.4

Weakness classification

References