high8.1
CVE-2021-21389
BuddyPress privilege escalation via REST API
Impact
### Impact It's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the BuddyPress REST API members endpoint. ### Patches The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue. ### References https://buddypress.org/2021/03/buddypress-7-2-1-security-release/ ### For more information If you have any questions or comments about this advisory: * Open an issue in [HackerOne](https://hackerone.com/wordpress)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | buddypress/buddypress | >= 5.0.0, < 7.2.1 | 7.2.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Buddypress | Buddypress | from 5.0.0 before 7.2.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://buddypress.org/2021/03/buddypress-7-2-1-security-release/
- https://codex.buddypress.org/releases/version-7-2-1/
- https://github.com/buddypress/BuddyPress/security/advisories/GHSA-m6j4-8r7p-wpp3
- https://github.com/advisories/GHSA-m6j4-8r7p-wpp3
- https://nvd.nist.gov/vuln/detail/CVE-2021-21389