NetSight
high7.7

CVE-2021-21414

Command injection vulnerability in @prisma/sdk in getPackedPackage function

Impact

### Impact As of today, we are not aware of any Prisma users or external consumers of the `@prisma/sdk` package who are affected by this security vulnerability. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. It only affects the `getPackedPackage` function and this function is not advertised and only used for tests & building our CLI, no malicious code was found after checking our codebase. ### Patches Fixed in - @prisma/sdk@2.20.0 (latest channel) - @prisma/sdk@2.20.0-dev.29 (dev channel) Pull Request closing this vulnerability [https://github.com/prisma/prisma/pull/6245](https://github.com/prisma/prisma/pull/6245) ### Acknowledgements This issue was discovered and reported by GitHub Engineer [@erik-krogh (Erik Krogh Kristensen)](https://github.com/erik-krogh). ### For more information If you have any questions or comments about this advisory: - Create a discussion in [the Prisma repository](https://github.com/prisma/prisma/discussions) - Email us at security@prisma.io

Affected packages

EcosystemPackageAffectedFixed in
npm@prisma/sdk< 2.20.02.20.0

Affected products

VendorProductAffected versions
PrismaPrisma
before 2.20.0

Weakness classification

References